Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Mercedes Sprinter 2 (Typ NCV3, Baumuster W906) & VW Crafter 1 - ab 2006 bis 2017 bzw. 2018
Benutzeravatar
sprintbaer
Ist öfters hier
Ist öfters hier
Beiträge: 27
Registriert: 04 Jun 2018 02:01

Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von sprintbaer » 11 Okt 2018 21:06

Hallo zusammen,

ich habe seit Neuestem ganz komische Phänomene an meinem Sprinter und weiß nicht so richtig, wo ich nach der Ursache suchen soll.

Erstmal vorweg:
Mein Bus (Sprinter 316 CD, EZ 8/2013, L2H3, AHK, 160 Tkm) fährt ohne Probleme.
Ich bin aktuell dabei ein Wohnmobil draus zu machen.

Vor kurzem fingen folgende Phänome an:

1. Im Stand (Motor aus):
Türen offen, Innenbeleuchtung eingeschaltet, Radio an
Auf einmal geht hinten, d.h. die Leuchte über Schiebe- und Hecktür ganz kurz Licht aus und wieder an.
Vorne leuchtet es weiter, Radio läuft auch, Bordspannung um die 12,5 V
Das Spiel mit dem Licht hinten kurz aus wiederholt sich alle 3 bis 5 Minuten.
Türen auf, zu, Licht an, aus, Zündung an, aus, Motor an, aus, Fahrzeug bewegt .... das Phänomen bleibt:
Erstes Phänomen: Im Stand geht alle paar Minuten regelmäßig hinten kurz die Innenbeleuchtung an und aus.


2. Angeblich Birne defekt
Ich hatte in einer Seitenleuchte (vorne links) außen mangels alternative eine LED Birne drin (von Philipps).
Hat komischerweise ohne CAN Fehler funktioniert. An anderen Seitenleuchtenpositionen ging immer der Lampenfehler im Instrumentenbrett an.
Ich habe dann trotzdem die LED Birne wieder gegen eine normale getauscht. Seitdem geht nach dem Motorstart die Fehlerlampe für kaputte Glühbirne an.
Wenn ich mit meinem iCarsoft Gerät den Speicher auslese, ist da allerdings nichts. Speicher löschen ändert auch nichts.
Zu früheren Zeitpunkten hat mir die Diagnose immer relativ genau "erzählt" wo ich die defekte Birne suchen muss.
Zweites Phänomen: Fehlerlampe Birne defekt leuchtet, es ist aber kein Fehler gespeichert und keine Birne defekt oder "falsch".


Aber ich lese diese Fehler aus (Diagnosegerät iCarsoft MB II):
90D4 CAN-Botschaft vom Steuergerät A1 (Kombiinstrument) fehlt
90D2 CAN-Botschaft vom Steuergerät N73 (Steuergerät EZS) fehlt
90D3 CAN-Botschaft vom Steuergerät N73 (Steuergerät EZS) fehlt
90D5 CAN-Botschaft vom Steuergerät N72/1 (Steuergerät OBF) fehlt
90D8 CAN-Botschaft vom Steuergerät N69/1 (Türsteuergerät Fahrer) fehlt
90D9 CAN-Botschaft vom Steuergerät N30/4 (Steuergerät ESP) fehlt
9022 (Türsteuergerät Fahrer) - Ausfall des Motor-CAN-Busses
Und jeweils:
DTC Status: gespeichert
Und u.a. folgende IST Werte (bei laufendem Motor):
Analogeingang Klemme 30 14,45 V
Analogeingang Klemme 15 14,33 V
Analogeingang Klemme 15R 14,41 V
Analogeingang Klemme 61 12,94 V
Ausgang Klemme 15 Ein
Ich kann auch alle möglichen anderen IST Werte auslesen. Z.B. ob ich den Fensterheberknopf betätige, oder den ASR Knopf, oder ob Fernlicht an, usw. Und es kommen valide Werte zurück. Will damit sagen, es sieht von den IST Werten her nicht so aus, als ob da was an Botschaften fehlen würde (bis auf die angeblich defekte Birne, die nur im Cockpit, aber nicht in der Diagnose angezeigt wird).

Die CAN-Bus Botschaft Fehler kann ich löschen, aber sie kommen nach kurzer Zeit wieder. Eventuell im Zusammenhang mit dem ersten mal Innenbeleuchtung an/aus Phänomen nach dem Löschen. Oder mit dem Aufleuchten der Birne defekt Lampe im Cockpit.

Ansonsten funktioniert alles (Fensterheber, Licht, Hupe, Tür offen Kontrolle, Tacho, Temp Anzeige usw.). Motor läuft auch super. Alles OK, bis auf oben genannte zwei Phänomene.

Obwohl, es gibt vielleicht noch ein drittes Phänomen:
Ebenfalls seit kurzem dreht der Motor nach dem ersten Motorstart manchmal kurz höher, als ich es von Beginn an gewöhnt war. Nicht richtig hoch, aber halt höher. Geht dann aber nach wenigen Sekunden auf normale Drehzahl wieder runter. Passiert aber auch nicht immer.
Dieses Phänomen ist aber schon ein paar Tage vor Phänomen 1 und 2 aufgetreten, auch vor unten beschriebenen Veränderungen.
Von daher würde ich es entweder als Zufall oder als Vorstufe werten.

Nun fragt ihr euch wahrscheinlich: Was hat der Typ (ich) gemacht? Was wurde verändert oder umgebaut?

Gute Frage:
Zuletzt habe ich eine Diesel Standheizung eingebaut.
Allerdings ist das oben genannte Phänomen 1 (mit der Innenbeleuchtung) schon aufgetreten bevor ich die Standheizung zum ersten Mal elektrisch angeschlossen und in Betrieb genommen habe.

ABER, ich habe die Standheizung in der Fahrersitzkonsole eingebaut. Dort sind ja ein paar Steckverbindungen und Sicherungen untergebracht, sowie das AHK Steuermodul. Diese Kabel habe ich bewegt und teilweise neu fixiert, den Sicherungshalter habe ich ein Loch höher festgeschraubt, nichts dramatisches also denke ich eigentlich.

UND ich hatte den Tank ausgebaut, um die Entnahme für die Heizung anzuschliessen. Dabei hatte ich natürlich die Verbindung zum Tankgeber getrennt. Aber das habe ich alles vor dem Absenken des Tanks getan, also habe ich nicht unsachgemäß Leitungen gedehnt. Und der Tankinhalt wird auch korrekt angezeigt.

ABER ich hatte während dieser Arbeiten nicht die Batterie abgeklemmt. Hätte ich das tun müssen?

Eine Woche vorher hatte ich auf beiden Seiten die Fahrer- und Beifahrertürverkleidung draußen und auch die Steckverbindungen gelöst.
Zweck der Übung war Kontrolle, Hohlraumschutz und ein bisschen Anti-Dröhn Massnahmen. Keine elektrische Veränderung.
Ich meine aber auch, dass im Anschluss daran noch keines der o.g. Phänomen auftrat.

Ansonsten gab es keine Veränderungen in jüngster Zeit, die sich nicht schon mehrere Wochen und über 1000 km im Betrieb als fehlerfrei erwiesen hätten (u.a. neues Radio).

Ich hoffe, ich habe alles exakt genug beschrieben und vielleicht kennt ja jemand von euch ein paar Diagnosen, die ich noch durchführen kann, oder hat einen Tip, wo der Fehler liegen kann, bevor ich in den sauren Apfel beissen und den Bus zum Freundlichen bringen muss.

Viele Grüße
Matthias
Sprinter 316 CDI EZ 08/2013 L2H3

Vanagaudi
Wird so langsam nervig
Wird so langsam nervig
Beiträge: 773
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie
Fahrerkarte

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von Vanagaudi » 11 Okt 2018 22:04

sprintbaer hat geschrieben:
11 Okt 2018 21:06
ABER ich hatte während dieser Arbeiten nicht die Batterie abgeklemmt. Hätte ich das tun müssen?
Wäre sicher besser gewesen. Ich hoffe, du hast deine Steuergeräte nicht geschrottet.

Ich habe gerade ein wenig beim PSM gelesen, und da wird explizit vorgeschrieben, in welcher Reihenfolge die zwei Stecker an- und abzustöpseln sind. Eigentlich ein Unding eine solche Vorschrift zu erlassen.

Jedenfalls ist SAM für die Lampensteuerung zuständig. Das hängt nur im Innenraum-CAN, und am LIN-Bus zum Generator. Die Diagnose-Buchse ist direkt mit dem EZS verbunden, welches als Gateway zwischen Innenraum-CAN, Motor-CAN und dem Diagnose-CAN fungiert.

Deine Fehlerbeschreibung zufolge scheint es sich um temporäre Störungen auf den CAN-Bussen zu handeln. Entweder spuckt da ein Gerät direkt Unsinniges aus, oder der Bus wird durch eine elektrische Fehlverbindung gestört.

Was mich noch interessiert: Hört das Blinken der Laderaumleuchte bei abgeschaltetem (geparktem) Wagen irgendwann auf? Das kann schon ein paar Minuten dauern. Der CAN-Bus und alle Steuergeräte müssten irgendwann in den Ruhezustand gehen und der Stromverbrauch müsste von rund 2A auf fast 0 sinken.
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Vanagaudi
Wird so langsam nervig
Wird so langsam nervig
Beiträge: 773
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie
Fahrerkarte

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von Vanagaudi » 11 Okt 2018 22:35

Die Seitenmarkierungsleuchten sind alle einzeln an SAM (N10) angeschlossen. Demnach dürfte es egal sein, wo du dein LED-Leuchtmittel einsetzt, die entsprechende Leuchte hätte immer ein Fehler melden müssen, auch vorne links. Da mit einem Glühfadenleuchtmittel nun ein Lampenfehler gemeldet wird, gehe ich davon aus, dass diese Leitung einen Zusatzverbraucher hat. Vielleicht auch SAM intern, das damit defekt wäre. Oder der Stromsensor in SAM ist defekt oder falsch eingestellt.

Code: Alles auswählen

N10 Stecker X2 Pin3; 0,75 swvi; E6/ 7 Seitenmarkierungsleuchte hinten links
N10 Stecker X2 Pin6; 0,75 swgn; E6/ 8 Seitenmarkierungsleuchte hinten rechts
N10 Stecker X2 Pin1; 0,75 swge; E6/ 9 Seitenmarkierungsleuchte vorn links
N10 Stecker X2 Pin4; 0,75 swws; E6/10 Seitenmarkierungsleuchte vorn rechts
N10 Stecker X2 Pin2; 0,75 swor; E6/11 Seitenmarkierungsleuchte mitte links
N10 Stecker X2 Pin5; 0,75 swgn (oder gror); E6/12 Seitenmarkierungsleuchte mitte rechts
Was hast du für ein Radio, und ist dieses am CAN-Bus angeschlossen?
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Benutzeravatar
sprintbaer
Ist öfters hier
Ist öfters hier
Beiträge: 27
Registriert: 04 Jun 2018 02:01

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von sprintbaer » 12 Okt 2018 01:19

Vanagaudi hat geschrieben:
11 Okt 2018 22:35
Was hast du für ein Radio, und ist dieses am CAN-Bus angeschlossen?
Ein Kenwood DDX4018DAB, ist aber nicht am CAN-Bus angeschlossen und schon seit mehreren Wochen problemlos in Betrieb.
Sprinter 316 CDI EZ 08/2013 L2H3

Benutzeravatar
sprintbaer
Ist öfters hier
Ist öfters hier
Beiträge: 27
Registriert: 04 Jun 2018 02:01

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von sprintbaer » 12 Okt 2018 01:36

Vanagaudi hat geschrieben:
11 Okt 2018 22:04
Was mich noch interessiert: Hört das Blinken der Laderaumleuchte bei abgeschaltetem (geparktem) Wagen irgendwann auf? Das kann schon ein paar Minuten dauern. Der CAN-Bus und alle Steuergeräte müssten irgendwann in den Ruhezustand gehen und der Stromverbrauch müsste von rund 2A auf fast 0 sinken.
Kurz zur Klarstellung:
Die Laderaumleuchten blinken nicht, sondern gehen im Abstand von mehreren Minuten kurz aus und wieder an. Es ist aber auch kein richtiges aus gehen, sondern eher ein schnelles runter und wieder hoch dimmen (fade-out, fade-in).

Zu deiner Frage:
Früher war es so, dass die Laderaumleuchten nach einer gewissen Zeit ganz ausgingen, bzw. runter gedimmt wurden.
Um dann das Licht wieder zu aktivieren musste ich den hinteren Lichtschalter einmal aus- und wieder einschalten. Oder alle Türen schliessen und wieder öffnen.
Aktuell bin ich mir nicht sicher, ob dieser Ausschaltzeitpunkt erreicht wird oder stattdessen nur dieses "Fade-out", "Fade-in" stattfindet ... so als ob der Ausschaltvorgang wieder abgebrochen wird.
Das müsste ich tatsächlich nochmal beobachten (und den Stromverbrauch messen und die Zeiten mal stoppen). Gefühlt findet dieser Ruhezustand nicht mehr statt, wenn ich drüber nachdenke.
Sprinter 316 CDI EZ 08/2013 L2H3

Benutzeravatar
sprintbaer
Ist öfters hier
Ist öfters hier
Beiträge: 27
Registriert: 04 Jun 2018 02:01

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von sprintbaer » 12 Okt 2018 01:38

Vanagaudi hat geschrieben:
11 Okt 2018 22:35

Code: Alles auswählen

N10 Stecker X2 Pin3; 0,75 swvi; E6/ 7 Seitenmarkierungsleuchte hinten links
N10 Stecker X2 Pin6; 0,75 swgn; E6/ 8 Seitenmarkierungsleuchte hinten rechts
N10 Stecker X2 Pin1; 0,75 swge; E6/ 9 Seitenmarkierungsleuchte vorn links
N10 Stecker X2 Pin4; 0,75 swws; E6/10 Seitenmarkierungsleuchte vorn rechts
N10 Stecker X2 Pin2; 0,75 swor; E6/11 Seitenmarkierungsleuchte mitte links
N10 Stecker X2 Pin5; 0,75 swgn (oder gror); E6/12 Seitenmarkierungsleuchte mitte rechts
Wo sitzt dieser Stecker?
Sprinter 316 CDI EZ 08/2013 L2H3

Benutzeravatar
sprintbaer
Ist öfters hier
Ist öfters hier
Beiträge: 27
Registriert: 04 Jun 2018 02:01

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von sprintbaer » 12 Okt 2018 02:05

Vanagaudi hat geschrieben:
11 Okt 2018 22:35
Die Seitenmarkierungsleuchten sind alle einzeln an SAM (N10) angeschlossen. Demnach dürfte es egal sein, wo du dein LED-Leuchtmittel einsetzt, die entsprechende Leuchte hätte immer ein Fehler melden müssen, auch vorne links.
Fakt ist, dass nun der Fehler signalisiert wird, egal ob ich die Glühfadenlampe oder die LED Lampe einsetze.
Ehrlich gesagt hat es ich mich auch gewundert, dass es mit der LED Lampe zuvor ohne Fehler ging.


Die Birnchen, die mir verkauft wurden (auf Basis meiner Fahrzeugscheindaten) haben 5 Watt und kommen mir etwas hell und heiss vor im Betrieb.
Aber 5 Watt stimmt doch, oder?
Sprinter 316 CDI EZ 08/2013 L2H3

Vanagaudi
Wird so langsam nervig
Wird so langsam nervig
Beiträge: 773
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie
Fahrerkarte

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von Vanagaudi » 12 Okt 2018 10:58

sprintbaer hat geschrieben:
12 Okt 2018 02:05
Die Birnchen, die mir verkauft wurden (auf Basis meiner Fahrzeugscheindaten) haben 5 Watt und kommen mir etwas hell und heiss vor im Betrieb. Aber 5 Watt stimmt doch, oder?
Da schaust du besser mal in deine Bedienungsanleitung unter Stichwort "Glühlampenwechsel". Bei den Fahrzeugen BJ 2015 sind zum Beispiel LED Leuchtmittel eingebaut.
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Benutzeravatar
sprintbaer
Ist öfters hier
Ist öfters hier
Beiträge: 27
Registriert: 04 Jun 2018 02:01

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von sprintbaer » 12 Okt 2018 19:03

War heute bei MB. Bei mir kommen W3W, also 3 Watt Glassockel rein.
Gut, habe die jetzt mal reihum alle 6 ausgetauscht.

Ändert leider nix. Im Gegenteil. Und ich befürchte Schlimmstes.
Als ich zum Auto kam, war es nicht verriegelt. Ich bin sicher, dass ich gestern abgeschlossen hatte.

Und folgender Fehler war jetzt zusätzlich zu den anderen schon genannten gespeichert:
9097 B24/15 ( Sensor Drehgeschwindigkeit, Quer- und Längsbeschleunigung) - Notöffnung
Oh nein, was ist das? Das Auto wurde nicht bewegt und öffnet sich von allein.
Die fehlende CAN-Botschafts Meldungen tauchen jetzt auch in anderen Modulen auf und ich kann sie gar nicht so schnell löschen, wie sie wieder auftauchen.

Jetzt habe ich mal die Batterie abgeklemmt und lasse das Auto über Nacht ruhen. Mal schauen (die Hoffnung stirbt zu letzt), vielleicht ist morgen alles wieder gut. Dieselheizung u.a. habe ich auch mal abgeklemmt, so dass alles so ist, wie es vorher auch fehlerfrei war.
Vanagaudi hat geschrieben:
12 Okt 2018 10:58
sprintbaer hat geschrieben:
12 Okt 2018 02:05
Die Birnchen, die mir verkauft wurden (auf Basis meiner Fahrzeugscheindaten) haben 5 Watt und kommen mir etwas hell und heiss vor im Betrieb. Aber 5 Watt stimmt doch, oder?
Da schaust du besser mal in deine Bedienungsanleitung unter Stichwort "Glühlampenwechsel". Bei den Fahrzeugen BJ 2015 sind zum Beispiel LED Leuchtmittel eingebaut.
Sprinter 316 CDI EZ 08/2013 L2H3

Vanagaudi
Wird so langsam nervig
Wird so langsam nervig
Beiträge: 773
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie
Fahrerkarte

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von Vanagaudi » 13 Okt 2018 10:09

sprintbaer hat geschrieben:
12 Okt 2018 19:03
9097 B24/15 ( Sensor Drehgeschwindigkeit, Quer- und Längsbeschleunigung) - Notöffnung
Oh nein, was ist das? Das Auto wurde nicht bewegt und öffnet sich von allein.
So gehört sich das mit der Notöffnung und ist richtig. :| Ich kann mich nur von oben wiederholen: Es gibt da offensichtlich ein Gerät, dass dem Standard konforme, aber dem Fahrzustand entsprechend unsinnige CAN-Botschaften ausgibt. Es geht scheinbar so weit, dass einige Geräte umprogrammiert wurden.

Für wie zuverlässig hältst du dein Diagnosegerät? Ist es denkbar, dass es sich hier um einen Clone handelt? Hast du schon mal mit einem SW-Update von icarsoft probiert?
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Vanagaudi
Wird so langsam nervig
Wird so langsam nervig
Beiträge: 773
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie
Fahrerkarte

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von Vanagaudi » 13 Okt 2018 10:16

sprintbaer hat geschrieben:
12 Okt 2018 01:38
Vanagaudi hat geschrieben:
11 Okt 2018 22:35

Code: Alles auswählen

N10 Stecker X2 [...]
Wo sitzt dieser Stecker?
Auf diesem Bild des Sprinter SAM kann man sehr deutlich die Steckerkennzeichnung lesen. Das Modul selbst sitzt unten links im Fahrerfußraum auf der Spritzwand.
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Crafter277
Wird so langsam nervig
Wird so langsam nervig
Beiträge: 630
Registriert: 30 Dez 2010 18:55
Wohnort: am Rhein

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von Crafter277 » 13 Okt 2018 10:19

CAN - Bus :mrgreen:
Schon mal die (alle !!!!) Masseverbindungen überprüft?
Oft liegt die Lösung eines Problemes an ganz einfachen Dingen.

Grüße Wolfgang
Crafter 35 -164 PS / 2009 / Westfalia Sven Hedin

Benutzeravatar
sprintbaer
Ist öfters hier
Ist öfters hier
Beiträge: 27
Registriert: 04 Jun 2018 02:01

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von sprintbaer » 13 Okt 2018 12:26

Hi,

erstmal vielen Dank für eure Unterstützung
Vanagaudi hat geschrieben:
13 Okt 2018 10:09
Es gibt da offensichtlich ein Gerät, dass dem Standard konforme, aber dem Fahrzustand entsprechend unsinnige CAN-Botschaften ausgibt. Es geht scheinbar so weit, dass einige Geräte umprogrammiert wurden.
Hm. :?: Ich habe exakt 3 "Fremdgeräte" in Betrieb bis dato:

1. Autoradio Kenwood DDX4018DAB
2. Solarladeregler Victron SmartSolar MPPT 75/15
3. Dieselstandheizung Planar 2D

Keines der 3 Geräte hat eine CAN Verbindung.

1 und 2 sind schon seit mehren Wochen und über 1000 km drin. Die würde ich ausschliessen.
3 ist frisch, aber kann eine Standheizung, die nur mit Plus und Minus angeschlossen ist, den CAN Bus so stören und dabei noch so valide Messages, wie Notöffnung generieren? Auch wenn sie gar nicht läuft?
Crafter277 hat geschrieben:
13 Okt 2018 10:19
Schon mal die (alle !!!!) Masseverbindungen überprüft?
Oft liegt die Lösung eines Problemes an ganz einfachen Dingen.
OK, guter Hinweis. Ich hatte ja auch gerade beide Vordertürverkleidungen demontiert und Stecker getrennt, Im Fahrersitzkasten Stecker vom AHK Steuergerät getrennt und Masseverbindungen am Bodenblech gelöst, Kabelbäume bewegt, Tank ab- und angebaut und, und, .... werde ich nochmal explizit alles durchchecken.

Wenn ich versuche zeitlich einzugrenzen, ab wann die CAN Bus Spinnereien anfingen, dann vermute ich mal, dass es mit dem periodischen Aus und An der Innenbeleuchtung anfing. Und das kann ich relativ genau eingrenzen auf den Zeitpunkt seitdem die Dieselheizung zwar eingebaut, aber noch nicht verkabelt war. Auch der Tank war zu dem Zeitpunkt noch nicht demontiert. D.h. ich habe vor allem an dem Kabel und Steckergeraffel unter dem Fahrersitz gearbeitet. Das ist gleichzeitig auch der jüngste Eingriff. Alles andere, wie Radio, etc. liegt schon viel weiter zurück.

Jetzt fällt mir noch ein, dass ich zu dem Zeitpunkt unter'm Fahrersitz einen ganz kurzen Kurzschluss verursacht hatte :oops: : Der Vorbesitzer hat vom dicken Batterie + Kabel ein Kabel abgezweigt, welches eine Steckdose in der Konsole versorgt. Zwischen Abzweig und Steckdose liegt zwar korrekt eine Absicherung, aber den Abzweig selbst hat er per in die Leitung gezwirbelter und gelöteter Litze gemacht. Als ich mir das angeschaut habe (Isolierband entfernt) bin ich kurz gegen Karosserie oder eine Schraube damit gekommen. Es hat aber nur ganz leise gefunkt und auch keine sichtbaren Spuren hinterlassen und es war auch keine Sicherung draussen. Habe ich damit möglicherweise ein Steuergerät nachhaltig gestört?
Vanagaudi hat geschrieben:
13 Okt 2018 10:09
Für wie zuverlässig hältst du dein Diagnosegerät? Ist es denkbar, dass es sich hier um einen Clone handelt? Hast du schon mal mit einem SW-Update von icarsoft probiert?
Ich habe es im Juli über Amazon gekauft (Verkäufer Amazon, kein fragwürdiger Marketplace Händler).
ich habe auch schon relativ zu Beginn ein Software Update von iCarsoft ohne Probleme aufgespielt.
Ich habe es schon mehrfach seitdem verwendet, z.B. als ich tatsächlich defekte Kennzeichenbeleuchtung hatte und es hat mir immer valide Meldungen zurück gegeben. Um deine Frage zu beantworten, ich halte es für zuverlässig und keinen Clone.

Nachwievor habe ich ja auch 2 + 1 Phänomene, die wohl für spinnenden CAN Bus sprechen:
1. die Innenraumbeleuchtung geht periodisch kurz aus- und an (und zwar mit Fade out und in)
2. die Birnenkontrollleuchte im Armaturenbrett leuchtet, obwohl alle Birnen in Ordnung sind
3. das Fahrzeug öffnet sich über Nacht im Stand selbständig (Notöffnung) - das ist neu

Nachher gehe ich an's Auto und klemme die über Nacht getrennte Batterie wieder an.
Dieselheizung und Solar Laderegler lasse ich mal getrennt, Autoradio bleibt ausgeschaltet.
Mal schauen, ob die Fehler noch da sind.
Falls ja, werde ich mit den Leitungs- und Steckverbindungsüberprüfungen weiter machen. Diesmal bei getrennter Batterie.

Viele Grüße
Matthias
Sprinter 316 CDI EZ 08/2013 L2H3

Vanagaudi
Wird so langsam nervig
Wird so langsam nervig
Beiträge: 773
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie
Fahrerkarte

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von Vanagaudi » 13 Okt 2018 15:37

sprintbaer hat geschrieben:
13 Okt 2018 12:26
ich habe auch schon relativ zu Beginn ein Software Update von iCarsoft ohne Probleme aufgespielt. [...] ich halte es für zuverlässig und keinen Clone.
Mit dem erfolgreichen Update sehe ich es auch so.
sprintbaer hat geschrieben:
13 Okt 2018 12:26
Der Vorbesitzer hat vom dicken Batterie-Kabel [unter'm Fahrersitz] ein Kabel abgezweigt, welches eine Steckdose in der Konsole versorgt. [Mit diesem Kabel] bin ich kurz gegen Karosserie oder eine Schraube damit gekommen.
Wenn diese Leitung tatsächlich direkt (über Sicherung) auf dem Batteriepluspol liegt, und der Kurzschluß gegen Masse erfolgte, gehe ich nicht davon aus, dass aus diesem Grund ein Steuergerät beschädigt wurde.
sprintbaer hat geschrieben:
13 Okt 2018 12:26
kann eine Standheizung, die nur mit Plus und Minus angeschlossen ist, den CAN Bus so stören
Ja, durchaus, dazu muss sie aber in Betrieb sein. Die Glühkerze in der Dieselstandheizung benötigt recht hohen Strom. Wird der ein- oder ausgeschaltet, kann von der entsprechenden Versorgungsleitung über magnetische Kopplung ein Impuls auf parallel verlaufende CAN-Bus-Leitungen erzeugt werden. Ganz schlimm wird es, wenn die Glühkerze über Pulsweitenmodulation gesteuert wird.

Wie sieht es in dieser Hinsicht mit dem MPPT-Regler aus? Der streut ganz sicher ein Störfeld aus, ist der auch im Fahrersitzkasten montiert?
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Benutzeravatar
sprintbaer
Ist öfters hier
Ist öfters hier
Beiträge: 27
Registriert: 04 Jun 2018 02:01

Re: Hilfe, meinem CAN Bus fehlen so viele Steuergeräte

Beitrag von sprintbaer » 13 Okt 2018 19:07

Vanagaudi hat geschrieben:
13 Okt 2018 15:37
Wie sieht es in dieser Hinsicht mit dem MPPT-Regler aus? Der streut ganz sicher ein Störfeld aus, ist der auch im Fahrersitzkasten montiert?
Tatsächlich habe ich ihn vor dem Urlaub provisorisch im Sitzkasten positioniert. Aber wie schon gesagt, so tat alles fehlerfrei über mehrere Wochen und viele KM. Die aktuellen Fehler treten erst auf seit ich angefangen habe die Dieselstandheizung einzubauen.
Allerdings habe ich aktuell beides komplett deaktiviert und von der Stromversorgung getrennt, um den Fehler einzugrenzen. Mehr dazu in Kürze.
Sprinter 316 CDI EZ 08/2013 L2H3

Antworten